# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(^(.*)[ ])(?=#[ a-z0-9]+))|(?=(^(.*))+)"
test_str = ("bar\n"
"fdsfsf345#3gt#$%3^#$T$#tr43r43\n"
"test spaces\n"
"\"test spaces\"\n"
"\"fdsfsf345#3gt#$%3^#$T$#tr43r43\" #comment\n"
"test spaces\" #comment\n"
"bar\n"
"\"\"\n"
"\"\"\"\"\n"
"foo1 #comment2\n"
"\"with space value\" #comment\n"
"'with quote value'\n"
"somestringstart\n"
"with spaces\" # a comment\n"
"bar")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.