// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\*{2}Start\*{2}(.*?)\*{2}End\*{2}").unwrap();
let string = "za e e**Start**Good1**End**ds dq**Start**Good2**End**sds df";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}