using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z]+(?:[_ ][a-z]+)*$";
string input = @"ag_b_cf_ajk
zva b c de
hh_b opxop a_b
axz_be
axz be
axz_be_j
axz be j";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}