#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\(groupid=\s+(?P<groupid>\d+)"
Local $sString = "seq_read_4k: (groupid= 0 jobs= 1): err= 0: pid= 7396: Wed Sep 2 14:07:25 2015" & @CRLF & _
" read : io= 72013 MB bw= 614510 KB/s iops= 153627 runt= 120001msec " & @CRLF & _
"-- " & @CRLF & _
"seq_read_128k: (groupid= 1 jobs= 1): err= 0: pid= 7463: Wed Sep 2 14:07:25 2015" & @CRLF & _
" read : io= 74277 MB bw= 633821 KB/s iops= 4951 runt= 120001msec " & @CRLF & _
"-- " & @CRLF & _
"rand_read_4k: (groupid= 2 jobs= 1): err= 0: pid= 7480: Wed Sep 2 14:07:25 2015" & @CRLF & _
" read : io= 4102.4 MB bw= 35006 KB/s iops= 8751 runt= 120001msec " & @CRLF & _
"-- " & @CRLF & _
"rand_read_1M: (groupid= 3 jobs= 1): err= 0: pid= 7497: Wed Sep 2 14:07:25 2015" & @CRLF & _
" read : io= 44963 MB bw= 383678 KB/s iops= 374 runt= 120002msec " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")