const regex = /(?:^\s*|\G)\s*(?:,\s*)?\K(\b\d{1,2}\b)(?=(?:\s*(?:,\s*)?\b\d{1,2}\b)*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\s*|\\G)\\s*(?:,\\s*)?\\K(\\b\\d{1,2}\\b)(?=(?:\\s*(?:,\\s*)?\\b\\d{1,2}\\b)*$)', 'gm')
const str = ` 1
1 2 3 3 4 5 7 17
1, 2,3,11,74
1,11,14, 15
111, 101
1 2 3 a
1, 25, 5.0
1,, 7, 80
1,11,14,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}