const regex = /\$\{.*\#each\s+(.*)\s+in\s+(.*)\s*\}([\w.\s\S]*)\$\{\#endeach\}/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$\\{.*\\#each\\s+(.*)\\s+in\\s+(.*)\\s*\\}([\\w.\\s\\S]*)\\$\\{\\#endeach\\}', 'i')
const str = `<script id="name-tmpl" type="text/html" data-source="items">
<div>
\${item.name}
</div>
</script>`;
const subst = `<%(function(_items){for(var i=0;i<_items.length;i++){var $1=_items[i];%>$3<%}($2))%>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);