package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,3}.?\d{0,3}\s[a-zA-Z]{2,30}\s[a-zA-Z]{2,15}`)
var str = `I live at 25 Architect Street. I know a guy over on 88 Cherry Lane.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}