re = /\d{1,3}.?\d{0,3}\s[a-zA-Z]{2,30}\s[a-zA-Z]{2,15}/
str = 'I live at 25 Architect Street. I know a guy over on 88 Cherry Lane.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end