$re = '/(\b3\.00\b)/';
$str = 'neki text 133.00 ima dodatno vrednost 3.00 itd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);