import Foundation
let pattern = #"(\d+)(?<!10)\.(\d+)(?<!192\.168)(?<!172\.(1[0-6]|2\d|3[0-1]))\.(\d+)\.(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
74.125.226.134
10.0.1.1
172.16.0.0
172.31.0.1
172.32.0.0
192.168.10.1
104.44.81.79
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)