#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<td><a href="(http:\/\/adi.sunyconnect.suny.edu:4610\/F\/\?request=\d{6,6}&func=find-b&find_code=sys&local_base=adi01pub)">(.*?)<b><br>(.*?) \/ (.*?)<\/b>"
Local $sString = "<html>" & @CRLF & _
"<head> " & @CRLF & _
"<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> " & @CRLF & _
"<meta http-equiv="Content-Language" content="en-us" /> " & @CRLF & _
"<link rel="stylesheet" type="text/css" href="/app/exlibris/sny_scripts/new_items_list/new_items.css" />" & @CRLF & _
"<title>Adirondack Community College Library - New Titles List</title>" & @CRLF & _
"<script type="text/javascript" src="http://www.sunyconnect.suny.edu/gbs_cover_art/gbs_covers.js"></script>" & @CRLF & _
"</head>" & @CRLF & _
"<body> " & @CRLF & _
"<a name="top"></a>" & @CRLF & _
"<table width="90%" align="center" border="0" cellpadding="0" cellspacing="0">" & @CRLF & _
"<table id="Table_01" width="100%" height="48" border="0" cellpadding="0" cellspacing="0">" & @CRLF & _
" <tr>" & @CRLF & _
" <td>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<table width="100%" border="0" cellspacing="0" cellpadding="0" align="center"> " & @CRLF & _
" <tr bgcolor="#006500"> " & @CRLF & _
" <td class="topbar" valign="bottom" align="right"> " & @CRLF & _
" <a href="http://www.sunyacc.edu/go.php?page=academics/library.html" class="blue" target=new title="link to the library " & @CRLF & _
"home page"> " & @CRLF & _
" <img src="http://adi.sunyconnect.suny.edu:4610/aleph/prod/adi/alephe/www_f_eng/icon/logo.gif" border="0" alt="Library " & @CRLF & _
"Logo" align="left"></a> " & @CRLF & _
" </td> " & @CRLF & _
"<!-- <td class="topbar" valign="middle" align="center"> " & @CRLF & _
" </td> -->" & @CRLF & _
" </tr> " & @CRLF & _
" </table> " & @CRLF & _
"" & @CRLF & _
"<center><h2>" & @CRLF & _
"Adirondack Community College Library<br>" & @CRLF & _
"New Titles List" & @CRLF & _
"</h2></center>" & @CRLF & _
"" & @CRLF & _
"<p>" & @CRLF & _
"" & @CRLF & _
"<center>" & @CRLF & _
"<font color="#006500"><b><i>" & @CRLF & _
"This list shows the most recent additions to the library collection. Items are in call number order. " & @CRLF & _
"<br>" & @CRLF & _
"Click on the title to get to the full catalog record.</i></b></font>" & @CRLF & _
"</center>" & @CRLF & _
"" & @CRLF & _
"</td></tr></table>" & @CRLF & _
"" & @CRLF & _
"<!-- Close table opened in header_2 -->" & @CRLF & _
"</table>" & @CRLF & _
"<table align="center" cellspacing="20">" & @CRLF & _
"<tr><td>" & @CRLF & _
"<a href="#A">A - General Works, Encyclopedias, Dictionaries<br>" & @CRLF & _
"<a href="#B">B - Philosophy, Psychology, Religion<br>" & @CRLF & _
"<a href="#C">C - History of Civilization, Archeology, Chronologies,<br>" & @CRLF & _
" Genealogy, Biography<br>" & @CRLF & _
"<a href="#D">D - History: General and World History<br>" & @CRLF & _
"<a href="#E">E - History: America<br>" & @CRLF & _
"<a href="#F">F - History: America - Regional, State<br>" & @CRLF & _
"<a href="#G">G - Geography, Environmental Sciences, Anthropology,<br>" & @CRLF & _
" Folklore, Recreation, Sports<br>" & @CRLF & _
"<a href="#H">H - Social Sciences<br>" & @CRLF & _
"<a href="#J">J - Political Science<br>" & @CRLF & _
"<a href="#K">K - Law<br>" & @CRLF & _
"</td><td>" & @CRLF & _
"<a href="#L">L - Education <br>" & @CRLF & _
"<a href="#M">M - Music, books about Music<br>" & @CRLF & _
"<a href="#N">N - Fine Arts<br>" & @CRLF & _
"<a href="#P">P - Language and Literature<br>" & @CRLF & _
"<a href="#Q">Q - Science<br>" & @CRLF & _
"<a href="#R">R - Medicine, Nursing, Pharmacology, Psychiatry<br>" & @CRLF & _
"<a href="#S">S - Agriculture<br>" & @CRLF & _
"<a href="#T">T - Technology, Engineering, Aeronautics,<br>" & @CRLF & _
" Photography, Handicrafts<br>" & @CRLF & _
"<a href="#U">U - Military Science<br>" & @CRLF & _
"<a href="#V">V - Naval Science<br>" & @CRLF & _
"<a href="#Z">Z - Library Science, Bibliography<br>" & @CRLF & _
"</td></tr>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"<table width="75%" align="center" border="0" cellpadding="0" cellspacing="0"><tr><td>" & @CRLF & _
"<h4>LC Call Number:</h4>" & @CRLF & _
"<font color="#000000" size="1"><a href="http://www.loc.gov/catdir/cpso/lcco/lcco.html" target="_new">" & @CRLF & _
"Guide to LC Classification</a> - (click for more information on the call letters for a subject)" & @CRLF & _
"</font></p>" & @CRLF & _
"" & @CRLF & _
"[<b><a HREF="#A">A</a></b>] [<b><a HREF="#B">B</a></b>]" & @CRLF & _
"[<b><a HREF="#C">C</a></b>] [<b><a HREF="#D">D</a></b>] [<b><a HREF="#E">E</a></b>]" & @CRLF & _
"[<b><a HREF="#F">F</a></b>] [<b><a HREF="#G">G</a></b>] [<b><a HREF="#H">H</a></b>]" & @CRLF & _
"[<b><a HREF="#J">J</a></b>] [<b><a HREF="#K">K</a></b>]" & @CRLF & _
"[<b><a HREF="#L">L</a></b>] [<b><a HREF="#M">M</a></b>] [<b><a HREF="#N">N</a></b>]" & @CRLF & _
"[<b><a HREF="#P">P</a></b>] [<b><a HREF="#Q">Q</a></b>]" & @CRLF & _
"[<b><a HREF="#R">R</a></b>] [<b><a HREF="#S">S</a></b>] [<b><a HREF="#T">T</a></b>]" & @CRLF & _
"[<b><a HREF="#U">U</a></b>] [<b><a HREF="#V">V</a></b>] [<b><a HREF="#Z">Z</a></b>]" & @CRLF & _
"<br>" & @CRLF & _
"</td></tr></table>" & @CRLF & _
"" & @CRLF & _
"<table width=80%><tr><td> </td></tr><tr><td align=right>" & @CRLF & _
"<font size=1>Last updated: Mon 01-25-2016</font>" & @CRLF & _
"</td></tr></table>" & @CRLF & _
"<table width=90% align=center border=0 cellpadding=0 cellspacing=0>" & @CRLF & _
"<tr><td> <A NAME="A"> </A><b><font size=+3>A</font></b></a></td><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="B"> </A><b><font size=+3>B</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233654&func=find-b&find_code=sys&local_base=adi01pub">BX1751.3 .C377 2015 Adirondack Community College Circulating<b><br>The Catholic Church / Michael Ruth, book editor.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="C"> </A><b><font size=+3>C</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="D"> </A><b><font size=+3>D</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233656&func=find-b&find_code=sys&local_base=adi01pub">DK508.852 .U39 2016 Adirondack Community College Circulating<b><br>Ukraine / Michael Ruth, book editor.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="E"> </A><b><font size=+3>E</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="F"> </A><b><font size=+3>F</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="G"> </A><b><font size=+3>G</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="H"> </A><b><font size=+3>H</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233657&func=find-b&find_code=sys&local_base=adi01pub">HC110.I5 I477 2016 Adirondack Community College Circulating<b><br>Income inequality / Noël Merino, Book Editor.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233652&func=find-b&find_code=sys&local_base=adi01pub">HQ766 .B4794 2016 Adirondack Community College Circulating<b><br>Birth control / Jack Lasky, book editor.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233655&func=find-b&find_code=sys&local_base=adi01pub">HV9471 .A49 2016 Adirondack Community College Circulating<b><br>America's prisons / Jack Lasky, book editor.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="J"> </A><b><font size=+3>J</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="K"> </A><b><font size=+3>K</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="L"> </A><b><font size=+3>L</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="M"> </A><b><font size=+3>M</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="N"> </A><b><font size=+3>N</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="P"> </A><b><font size=+3>P</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233650&func=find-b&find_code=sys&local_base=adi01pub">PC2129.E5 R59 2009 Adirondack Community College Circulating<b><br>Easy French step-by-step : master high-frequency grammar for French proficiency--fast! / Myrna Bell</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233648&func=find-b&find_code=sys&local_base=adi01pub">PF3271 .H39 2011 Adirondack Community College Circulating<b><br>German verb drills / Astrid Henschel.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233658&func=find-b&find_code=sys&local_base=adi01pub">PN1997.2 .I54 2015 Adirondack Community College DVD<b><br>Infinitely polar bear / a Sony Pictures Classics release ; Paper Street Films and Park Pictures pres</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233649&func=find-b&find_code=sys&local_base=adi01pub">PR830.W6 P45 2014 Adirondack Community College Circulating<b><br>Women's fiction : from 1945 to today / Deborah Philips.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="Q"> </A><b><font size=+3>Q</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="R"> </A><b><font size=+3>R</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233647&func=find-b&find_code=sys&local_base=adi01pub">RB115 .B823 2016 Adirondack Community College Reference<b><br>2016 ICD-10-CM for physicians professional edition / Carol J. Buck.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="S"> </A><b><font size=+3>S</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233651&func=find-b&find_code=sys&local_base=adi01pub">S596.7 .V57 2015 Adirondack Community College Circulating<b><br>Visual soil evaluation : realizing potential crop production with minimum environmental impact / edi</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="T"> </A><b><font size=+3>T</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> </td><td><a href="http://adi.sunyconnect.suny.edu:4610/F/?request=233653&func=find-b&find_code=sys&local_base=adi01pub">TK5105.8855 .I58 2016 Adirondack Community College Circulating<b><br>The Internet / Jack Lasky, Book Editor.</b></a></td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="U"> </A><b><font size=+3>U</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="V"> </A><b><font size=+3>V</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"<tr><td> <A NAME="Z"> </A><b><font size=+3>Z</font></b></td><td><a HREF="#top">Back to top</a> </td></tr><tr><td> </td></tr>" & @CRLF & _
"</table>" & @CRLF & _
"</body>" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")