$re = '/(?P<message_type>[^.]query|response)\:/m';
$str = 'Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 26818 from 10.190.48.12#13258: view none: query: v-ipr-webproxy.i.np2.navy.mil IN A + (10.190.44.87%0)
Feb 3 00:42:32 ipywa1559.i.np2.navy.mil tmm[19902] 2021-02-03 00:42:32 ipywa1559.i.np2.navy.mil qid 57035 to 10.190.48.12#13258: [NOERROR qr,aa,rd] response: v-ipr-webproxy.i.np2.navy.mil
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);