const regex = /^[^0-9A-Z]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^0-9A-Z]+$', 'gm')
const str = `Abc0Z
+++++`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);