import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-zA-Z])(?=.*[0-9])";
final String string = "476dn65\n"
+ "e586\n"
+ "9999\n"
+ "rrr\n"
+ "ABCF\n"
+ "01G5PFZD4ZQKKQTTB0YG22N264\n"
+ "01g5asd12312asd\n"
+ "customer\n"
+ "01G5PFZD4ZQKKQTTB0YG22N264\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}