#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^http[s]{0,1}:\/\/(.*?)(?:[\/?&#]|$)"
Local $sString = "http://abc.com#" & @CRLF & _
"http://abc.com.asdoasd&sds" & @CRLF & _
"http://abc.com.co" & @CRLF & _
"http://abc.com.co?&xp=wer" & @CRLF & _
"http://abc.com.co/p" & @CRLF & _
"http://abc.com?p" & @CRLF & _
"https://abc.com?p"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")