package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^http[s]{0,1}:\/\/(.*?)(?:[\/?&#]|$)`)
var str = `http://abc.com#
http://abc.com.asdoasd&sds
http://abc.com.co
http://abc.com.co?&xp=wer
http://abc.com.co/p
http://abc.com?p
https://abc.com?p`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}