#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ *([^\s:-][^\s:]*) *: *(.+)$"
Local $sString = "containers:" & @CRLF & _
" - name: api-php-container" & @CRLF & _
" image: us-west-2.amazonaws.com/abcd:45" & @CRLF & _
" ports:" & @CRLF & _
" - containerPort: 80" & @CRLF & _
" - containerPort: 443" & @CRLF & _
" volumeMounts:" & @CRLF & _
" mountPath: "/etc/keys/ssl"" & @CRLF & _
" - name: certs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")