package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *([^\s:-][^\s:]*) *: *(.+)$`)
var str = `containers:
- name: api-php-container
image: us-west-2.amazonaws.com/abcd:45
ports:
- containerPort: 80
- containerPort: 443
volumeMounts:
mountPath: "/etc/keys/ssl"
- name: certs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}