import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ *([^\\s:-][^\\s:]*) *: *(.+)$";
final String string = "containers:\n"
+ " - name: api-php-container\n"
+ " image: us-west-2.amazonaws.com/abcd:45\n"
+ " ports:\n"
+ " - containerPort: 80\n"
+ " - containerPort: 443\n"
+ " volumeMounts:\n"
+ " mountPath: \"/etc/keys/ssl\"\n"
+ " - name: certs";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}