using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![\!@#\$%\^&\*\(\)\:\""\<\>\?\/,] [a-z][1-9])^(([A-Z]{1}[a-z0.']+)+( ?[A-Z]{1}[a-z0.]+))*";
string input = @"Smith
S0resen
O'Smith
Sm#ith
Smi3th
S0mith
smith
Mc Smith
Smith
Mc Muffin
McMutton
Mc Mutton
Mc mutton
O'riley
O'Riley";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}