$re = '/(([\s]*)(\/\/[\s]*\<debug\>)([\r\n\s]*))?Ext\.Logger\.(error|warn|log)\(\s*[\'"](.*)[\'"]\s*\)\;(([\n\s]*)(\/\/[\s]*\<[\/]?debug\>)([\r\n\s]*))?/';
$str = ' // <debug>
Ext.Logger.error(\'form returns no value\');
// </debug>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);