re = /define+\(["' ](.*)["' ], ["' ](.*)[ "']\);/
str = 'define("CONSTANT", "VALUE");
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end