# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<p(?: [^>]+)?>((?:(?!<\\/?p[ >]).)*)<\\/p>/$1/igsm;t' <<< "<p style=\"text-align: right;\">
<p style=\"text-align: center;\">
<p style=\"text-align: left;\">
<p style=\"text-align:center;\">
leave this content
</p>
</p>
</p>
</p>"