use strict;
my $str = '<p style="text-align: right;">
<p style="text-align: center;">
<p style="text-align: left;">
<p style="text-align:center;">
leave this content
</p>
</p>
</p>
</p>';
my $regex = qr/<p(?: [^>]+)?>((?:(?!<\/?p[ >]).)*)<\/p>/ismp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";