# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<p(?: [^>]+)?>((?:(?!<\/?p[ >]).)*)<\/p>"
test_str = ("<p style=\"text-align: right;\">\n"
" <p style=\"text-align: center;\">\n"
" <p style=\"text-align: left;\">\n"
" <p style=\"text-align:center;\">\n"
" leave this content\n"
" </p>\n"
" </p>\n"
" </p>\n"
"</p>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.DOTALL | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.