$re = '/(,?[a-zA-Z][a-zA-Z0-9]*,?)/';
$str = 'red, 1 ,yellow, 4, red1, 1yellow yellow
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);