# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*Your Username:.(.*)(?!.Your Password)$/$1/sg;t' <<< "Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234"