using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*Your Username:.(.*)(?!.Your Password)$";
string substitution = @"$1";
string input = @"Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}