$re = '/^.*Your Username:.(.*)(?!.Your Password)$/s';
$str = 'Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;