import Foundation
let pattern = #"^.*Your Username:.(.*)(?!.Your Password)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
Subscription/Member ID: 1655107153 Your Username: jose1234
Your Password: jose1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)