$re = '/^[A-Z]{2},[A-Z0-9\W]*,[A-Z]{1},[A-Z0-9\W]*,[a-z\W]{6},[A-Za-z]*,[0-9\W]{11},[0-9]{10},[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*$/m';
$str = 'NS,FHS1,A,SHAMSTABRIZI AMIRHOSSEIN,en-usa,Create,33749-07305,9028356191,Message: closed.completed.all,Passed,Wed May 02 08:00:37 ADT 2018';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);