# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Z]{2},[A-Z0-9\W]*,[A-Z]{1},[A-Z0-9\W]*,[a-z\W]{6},[A-Za-z]*,[0-9\W]{11},[0-9]{10},[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*,[a-zA-Z0-9\W]*$"
test_str = "NS,FHS1,A,SHAMSTABRIZI AMIRHOSSEIN,en-usa,Create,33749-07305,9028356191,Message: closed.completed.all,Passed,Wed May 02 08:00:37 ADT 2018"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.