const regex = new RegExp('(\\.) ', 'gm')
const str = `Какой-то текст. Дальше идет совсем другой текст.`;
const subst = `.\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);