using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Examples of fruits are (?>((?>bananas|apples|grapes|pears))(?![^.]*?\b\1\b)(?>,\s*+|\s++and\s++)?)++\.$";
string input = @"Examples of fruits are apples, bananas, pears and grapes.
Examples of fruits are apples, bananas, grapes and pears.
Examples of fruits are bananas, pears and grapes.
Examples of fruits are apples, bananas, pears and pears.
Examples of fruitz are apples, bananas, pears and grapes.
Examples of fruits are kiwis, apples, bananas, pears and grapes.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}