import Foundation
let pattern = #"^Examples of fruits are (?>((?>bananas|apples|grapes|pears))(?![^.]*?\b\1\b)(?>,\s*+|\s++and\s++)?)++\.$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Examples of fruits are apples, bananas, pears and grapes.
Examples of fruits are apples, bananas, grapes and pears.
Examples of fruits are bananas, pears and grapes.
Examples of fruits are apples, bananas, pears and pears.
Examples of fruitz are apples, bananas, pears and grapes.
Examples of fruits are kiwis, apples, bananas, pears and grapes.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)