$re = '/<script src="common(?![\w\/]+config.js)/';
$str = '<script src="common/scripts/vendor.0.js"></script>
<script src="common/scripts/all.0.js"></script>
<script src="common/scripts/source/config.js"></script>';
$subst = "<script src=\"//cdn.domain.common";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;