const regex = /\b\d{5}(?!-\d{1,3}\b|-\d{5})(?:-\d{4})?\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{5}(?!-\\d{1,3}\\b|-\\d{5})(?:-\\d{4})?\\b', 'g')
const str = `This is a sentence with multiple zip codes: 12345-1235 and 12345 and some false zip codes: 12345-123566, 12345-12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}