using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name=""__RequestVerificationToken"" type=""hidden""\s*value=""(.+?)"" ";
string input = @"<input name=""__RequestVerificationToken"" type=""hidden""
value=""BeRYiSIRjZoQHq4VW8qbkgXlnnzdUINpFNoYF_ugx-FRk0tkImbQPhwyYjyz_0Q-w6F2A0gDOfMZrdklD6rVn6-QnYggfImb55f90V7nrD_kbSkT3-y3gPqoTFg0ynTBLyX5Lw2"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}