// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<p>(.+)\[…\]<\/p>").unwrap();
let string = "<p>Am 15. Februar 2016 erschein Rage of Bahamut: Genesis Exklusive bei Amazon in einer limitierten Version inklusive Soundtrack im Mediabook auf DVD und Blu-ray, die Einzel Veröffentlichung in zwei Volumes folgt dann im April und Mai. Wer den Anime gern sehen will, hat jetzt bei Clipfish die Chance. Dort gibt es alle zwölf Folgen im […]</p>
<p>Der Beitrag <a rel=\"nofollow\" href=\"https://www.animenachrichten.de/rage-of-bahamut-genesis-neu-bei-clipfish/\">Rage of Bahamut: Genesis neu bei Clipfish</a> erschien zuerst auf <a rel=\"nofollow\" href=\"https://www.animenachrichten.de/\">AnimeNachrichten - Aktuelle Nachrichten rund um Anime, Manga, Games und das TV Programm</a>.</p>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}