#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Description\h*:\h*vusb0/iDRAC\h*Network/.*(?:.*\R)+?IPv4 Address\h+:\h*(\d{1,3}(?:\.\d{1,3}){3})"
Local $sString = "lo0" & @CRLF & _
"Description : lo0" & @CRLF & _
"Status : Up" & @CRLF & _
"Interface Type : Loopback" & @CRLF & _
"DHCP : Disabled" & @CRLF & _
"MAC Address : 30-03-27-E3-3B-03" & @CRLF & _
"FQDD : Not Applicable" & @CRLF & _
"IPv4 Address : 127.0.0.1" & @CRLF & _
"Subnet Mask : 255.0.0.0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"vmk0" & @CRLF & _
"Description : vmnic0/Management Network/vmk0" & @CRLF & _
"Status : Up" & @CRLF & _
"Interface Type : Ethernet" & @CRLF & _
"DHCP : Enabled" & @CRLF & _
"DHCPServerV4 : 100.98.65.10" & @CRLF & _
"MAC Address : 50-9A-4C-9C-99-8D" & @CRLF & _
"FQDD : NIC.Embedded.1-1-1" & @CRLF & _
"IPv4 Address : 100.98.68.239" & @CRLF & _
"Subnet Mask : 255.255.252.0" & @CRLF & _
"IPv6 Address : fe80::529a:4cff:fe9c:998d" & @CRLF & _
"Prefix Length : 64" & @CRLF & _
"IPv4 Gateway Address : 100.98.68.1" & @CRLF & _
"IPv4 DNSServer Address 0: 10.7.7.7" & @CRLF & _
"IPv4 DNSServer Address 1: 10.8.8.8" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"vmk1" & @CRLF & _
"Description : vusb0/iDRAC Network/vmk1" & @CRLF & _
"Status : Up" & @CRLF & _
"Interface Type : Ethernet" & @CRLF & _
"DHCP : Disabled" & @CRLF & _
"MAC Address : 00-50-56-6E-6F-99" & @CRLF & _
"FQDD : Not Applicable" & @CRLF & _
"IPv4 Address : 169.254.10.12" & @CRLF & _
"Subnet Mask : 255.255.255.0" & @CRLF & _
"IPv6 Address : fe80::250:56ff:fe6e:6f99" & @CRLF & _
"Prefix Length : 64" & @CRLF & _
"IPv4 DNSServer Address 0: 10.7.7.7" & @CRLF & _
"IPv4 DNSServer Address 1: 10.8.8.8" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"vmk2" & @CRLF & _
"Description : vmnic1/iDRAC Network/vmk2" & @CRLF & _
"Status : Up" & @CRLF & _
"Interface Type : Ethernet" & @CRLF & _
"DHCP : Disabled" & @CRLF & _
"MAC Address : 00-50-56-6E-6F-99" & @CRLF & _
"FQDD : Not Applicable" & @CRLF & _
"IPv4 Address : 169.254.3.1" & @CRLF & _
"Subnet Mask : 255.255.255.0" & @CRLF & _
"IPv6 Address : fe80::250:56ff:fe6e:6f99" & @CRLF & _
"Prefix Length : 64" & @CRLF & _
"IPv4 DNSServer Address 0: 10.7.8.9" & @CRLF & _
"IPv4 DNSServer Address 1: 10.3.2.1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"racadm>>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")