#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(["'])((?:\\\1|(?:(?!\1)).)*)(\1)"
Local $sString = "The sentence is 'He said "Hello there"'" & @CRLF & _
"The sentence is 'He said \'Goodbye\''" & @CRLF & _
"The sentence is 'Let\'s go!'" & @CRLF & _
"" & @CRLF & _
"The sentence is "He said 'Hello there'"" & @CRLF & _
"The sentence is "He said \"Goodbye\""" & @CRLF & _
"The sentence is "Let's go!"" & @CRLF & _
"" & @CRLF & _
"The sentence is "Double quote: \""" & @CRLF & _
"The sentence is "It's double quote: \""" & @CRLF & _
"" & @CRLF & _
"Uncorrect line:" & @CRLF & _
"The sentence is 'Let's go!'" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")