const regex = /(["'])((?:\\\1|(?:(?!\1)).)*)(\1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(["\'])((?:\\\\\\1|(?:(?!\\1)).)*)(\\1)', 'g')
const str = `The sentence is 'He said "Hello there"'
The sentence is 'He said \\'Goodbye\\''
The sentence is 'Let\\'s go!'
The sentence is "He said 'Hello there'"
The sentence is "He said \\"Goodbye\\""
The sentence is "Let's go!"
The sentence is "Double quote: \\""
The sentence is "It's double quote: \\""
Uncorrect line:
The sentence is 'Let's go!'
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}