re = /(?:(?<=\|)( *+)[^|]*?( *+)(?=\|))*/
str = '<p>| | dade |</p>
<p>| SAUDE CAIXA - DESENVOLVIMENTO|</span></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end