package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([1-9])|([1-9][0-9])|(1[0-9][0-9]))$`)
var str = `200`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}