const regex = /^[A-Z]{2}[0-9]{2}[A-Z]{2}[0-9]{3}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{2}[0-9]{2}[A-Z]{2}[0-9]{3}$', 'g')
const str = `DE34IP315 9 - CASCADE - Found
WA54XC875 9 - CASCADE
WA33XC032 9 - CASCADE
AT99XT805 9 - CASCADE
BI99XT003 9 - CASCADE
CI99XT048 9 - CASCADE
CH03XC397B 10 - CASCADE
CI03XC610 9 - CASCADE
DE34IP936 9 - CASCADE
CR03AW194 9 - CASCADE
ADAMIAG 7 - NSC
LEEVAAA 7 - NSC
LEEVAAB 7 - NSC
COW-AT99XT805 13 - NSC
COW-BI99XT003 13 - NSC
COW-CI99XT048 13 - NSC
HGPKILPI 8 - NSC
WCHSOHDJ 8 - NSC
WHTHMIAA 8 - NSC
LDSNSCAD 8 - NSC
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}