$re = '/^(.+)\t[0-9]+\n\1\t●/m';
$str = 'Collection 47
Collection ●
CollectionIdentifier 50
CollectionIdentifier ●
CollectionIDType 51
CollectionIDType ●
CollectionSequence 52
CollectionSequenceNumber 55
CollectionSequenceType 53
CollectionSequenceTypeName 54
CollectionType 48
CollectionType ●
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);