use strict;
my $str = 'דחוףףףףףףףףףף';
my $regex = qr/([א-ת])(\1{2})\1+/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";