$re = '/^([^,]*),([^,]*),([^,]*),(.*),(\d+)\s*$/m';
$str = '2014-12-24 13:37:00,1.2.3.4,root,password,0
time,ip,user,,,,pass,,,,1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);