using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\.\d+\.\d+)(?>\-.*?\.)(\d+)";
string input = @"https://d1swzmic55peuz.cloudfront.net/7.0.1-5xTesi.101/
https://d1swzmic44peuz.cloudfront.net/7.0.0-bathrolls.103/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}