re = /(\d+\.\d+\.\d+)(?>\-.*?\.)(\d+)/m
str = 'https://d1swzmic55peuz.cloudfront.net/7.0.1-5xTesi.101/
https://d1swzmic44peuz.cloudfront.net/7.0.0-bathrolls.103/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end